Below follow some tips & tricks how to get started with Helium.

Helium can be used in many ways and the more experienced you will be with it, you might find alternate workflows that suits you better.

Adding files to the library

The most views in Helium is database driven, meaning that it will use the data indexed in your Library to build the contents.

Therefore, the first step you will need to perform is to index your music in your Library.

You will do this by:

1) Select File > Add music > Add files to Library

2) From the dialog shown, choose the root folders you would like to add by clicking the Add button. Each selected folder will be scanned recursiely for audio files.

3) Click OK to start the indexing of files

During the indexing, Helium will:

  • Read tags from each found file and create a track entry in your Library
  • From all files found, create albums and group tracks into the best matching album.
  • From all files found, create unique artists and connect tracks and albums to each artist
  • From all files found, create unique labels and connect tracks and albums to each label
  • Calculate rating and various summary information for albums, artists and labels.

After the adding is completed, you can start to work with the various views in Helium and explore your music collection.


If you have a lot of files with little or no tag information, it can be a good idea to add some basic metadata to your files before you start adding files to your Library.

An efficient way to accomplish this is by:

  • Opening the My Computer view (Left navigation pane or View > Views menu)
  • Select a folder or files to work with by clicking the buttons "Select folder"/"Add files..."
  • Start any of the tag editors and enter metadata manually or by using the Filename to tag tool.

Tagging and correcting track meta data

When you have added files to your Library you can easily browse it in various ways from the different views in Helium.

Whilst browsing you might locate items (tracks/artists/albums) that has incomplete or misspelled information.

To correct this use any of the Tag editors available from the Tools > Tags menu. It is also possible to use the Quick editor from some of the views or inplace editing, which can be a very quick way to correct misspellings.

Which tag editor that you choose to work with is a personal choise, generally the Tag editor is a good choise since it can handle all fields and assist with batch operations. For more customized needs, you can choose to work with the Advanced tag editor and personalized templates.

Click here for more information about Heliums tag editors.

After you have edited tags, the changes will update the database to reflect the new data instantly and after that be saved to the tags on the files. The file saving operations will be executed in background, allowing you to continue to work with Helium.

Renaming files

Depending on how you work with Helium you might come to a point when you would like to rename your files based on the (updated) meta data from the tags on your files.

One way of working with Helium is to keep "incompete" items in a separate folder. From this folder, you can tag an album and once tagged, rename it using the Rename tool.

The Rename tool will use a customized rule-based template to generate new folder and filenames based on the metadata stored in each file.

During the renaming you can choose to either rename and copy the files to it's new location or to rename and move the files to the new location.

By using rename and move files to another location in combination with storing files in an "incomplete" folder, you can easily move "completed" (tagged) files to another folder/drive to be able to easily keep track of which items that remains to be tagged and which that are tagged.

Click here for more information about the Rename tool

Updating your library with new files

If you have one or more folders of files that does not exist in your Library, you should use the Update Library tool to add new items to your Library.

You can use the Add files to Library tool to do the same, but the Update Library tool is more efficiant for this purpose.

What this tool will do is to:

  • Check your library if any files have been updated from outside Helium. If so, their contents will be re-read and your Library updated with the new contents
  • Check if any items that are indexed in your Library has been removed. If so, they will be removed from your Library.
  • Locate files that exists on your discs but not yet in your Library. These files will be added to your Library using the same logic as described in Adding files to the Library above.

Click here for more information about the Update Library tool

Browsing your Library

As mentioned earlier, Helium allows you to browse your Library in many ways.

All available views are available from the left navigation bar or from the Views menu.

Each view in Helium is generally based on some kind of grouping or many groupings.

Below follows a short description of each available root view. 

  • Music Explorer - This view is one of the more complex views in Helium which allows you to browse your data in many ways. It is possible to browse files in the same way as in WIndows Explorer (using the Library node), by artist, albums, genres, custom fields and much more. Some of the nodes can also be customized so that you can define your own groupings to suit your needs. NOTE: Select a node and press F5 to force a refresh of it's childs
  • Releases view - This view allows you to browse your collection based on releases (Albums, EPs and so on). Items will generally be shown as a "full" release together with a cover (if available). 
  • Artists view - This view is similar to the releases view, but based on artists instead.
  • Labels view - This view is similar to the releases view, but based on labels instead.
  • My Computer - This view displays tracks in a list, which is not necesarily added to your Library yet
  • Tracks - This view allows you to browse all tracks in your Library
  • Playlists - This view allows you to create and manage Playlists and Smart playlists
  • Genres - This view will allow you to select a specific genre from a list showing all distinct genres in your Library and to the right of that list, Artists, Albums and Tracks from that genre will be shown
  • Years - Similar to the genre view, this view will allow you to choose a specific year in your Library from a list and to the right of that list, Albums and Tracks from that year will be shown
  • Statistics - This view will display statistics in various ways of your Library
  • Search results - This view will display results from searches (Artists, Albums and Tracks)

Many of the views will reuse the same type of rendering of items. For example, many of the track lists can be displayed just as track lists, but also as releases. Releases will use the same type of look and behaviour on all views, so if you have learned how it works, it will work in the same view no matter which view it relates to.


Many of the views supports filtering, both simple and advanced filtering.

By working with filters you can reduce the number of items shown in a view and more efficiently locate and work with specific items.

Playing music

Playing music in Helium is very straightforward. Each view supports playback of what you see, meaning that if you play a release, you will by default play all tracks from that release.

Playing a single track from a track list will do just that.

If you have Helium Streamer, you can easily access your music from any webbrowser as well as via native apps for iOS and Android.

More details about Helium Streamer can be found at:

Click here for more information about playing music in Helium


Helium comes with a lot of ways to explorer, play and work with your music collection.

The above topics is just a brief introduction to how to get started with Helium, after a while you might find your own workflow.

To get used to the various concepts and tools in Helium, we recommend you to experiment with the different views and tools as well as reading the available documentation and tips.

If you need any further help with a specific function or workflow, please try our forums or support.