Start a new topic

Connecting to Remote SQL Server Express Database

Just updated to HMM 12, and while doing so installed SQL Server Express in accordance with documents found on this forum.  The LOCAL install went OK.  I have not yet been able to get HMM12 on a different machine (Both Windows 10) to connect to the database.  The protocols are enabled, the ports are open in the server's firewall, SQL browser service is running, the TCP-IP port is enabled, and the user on the remote machine can connect to the file store on the server.  


Is HMM 12 supposed to be able to to connect to a remote database?  If I can connect using SSMS (not proven yet, but am working on it), is there anything else I need to do to get HMM 12 to connect?


Thanks in advance for any tips!


Do you have the right user name and password to connect remotely?  The user name should be sa and the password should be what you entered when configuring SQLEXPRESS.

 

Yes, I used SQL authentication and supplied sa and correct sa password that works locally.  The only thing I didn't try yet is logging in to both machines with the same Windows UID... but I did open the data store using the correct windows UID prior to trying the connection.  

As long as you can connect from another machine using SSMS, the same credentials should work well in Helium.

 SQL express by default doesn't enable the TCP/IP protocol, it uses shared memory.  You need to enable TCP/IP and you also will need to make sure your local firewall is open to 1433

I figured it out.  When I first posted, I had gone through the SQL Server Configuration Manager and enabled the TCP/IP port as Joe mentioned, above, AND opened the firewall for Ports 1433 and 1434.  I had the right user ID for "sa".  I had user rights to see all the needed files.  So, what was missing?  


I needed to add "sqlsrvr.exe" to a firewall rule.  Once that was done, the connection was made.


Still problems, though, because of problematic design of how to record in database where Artist, Album, and Label photos are stored.  That's the subject of a different post, though.

Login or Signup to post a comment